WCPP 5.0 for Windows, macOS and Linux clients Update – Fix EPdfUnsupportedFeatureException and PDF invalid password issues

A new update to WebClientPrint Processor 5.0 for macOS and Linux clients were just released. This new update includes:

    • Fixed! Error “EPdfUnsupportedFeatureException” with some PDF files.
    • Fixed! Error “Password required or invalid password” with encrypted PDF files that do not require password.

This update requires the installation of the client software only.

Download WebClientPrint Processor 5.0 for Windows, macOS and Linux

The “File version” value for this update is:

> wcpp.exe for Windows patched to v5.0.20.127
> wcpp5 app for macOS patched to v5.0.20.127
> wcpp5 app for Linux patched to v5.0.20.127

WCPP 5.0 for macOS and Linux clients Update – Fix PDF printing

A new update to WebClientPrint Processor 5.0 for macOS and Linux clients were just released. This new update includes:

  • Fixed! PDF was printed with some offset.
  • Fixed! Some PDF containing alpha channel or transparency colors were not printed correctly.

This update requires the installation of the client software only.

Download WebClientPrint Processor 5.0 for macOS and Linux

The “File version” value for this update is:

> wcpp5 app for macOS patched to v5.0.19.1126
> wcpp5 app for Linux patched to v5.0.19.1121

WebClientPrint under macOS 10.15 Catalina

WebClientPrint Processor App v4 (and any older version) is a 32-bit App and it will not work under the brand new macOS 10.15 Catalina.

Apple has decided that starting with Catalina, all apps must be 64-bit only. With that move from Apple devs, we’ve decided that starting with our brand new WebClientPrint Processor v5, the WCPP App will now be compiled to 64-bit systems and we’re also stop supporting 32-bit for both macOS and Linux.

So, if you’re using WebClientPrint 4.0 (or earlier) and want to use it in macOS 10.15 Catalina, then the only options is to¬†upgrade both your website and your Mac clients to WebClientPrint 5.0

Migrate to WebClientPrint 5.0

To migrate your website/server code to WebClientPrint 5.0, please read the Migration Guide for ASP.NET and PHP

After that, each Mac client must install WCPP v5 and it should be ready to work with your updated website

WCPP 4.0 for Mac clients Update – Fixed IP printers were not correctly detected

We’re glad to announce a new update to WebClientPrint Processor 4.0 for macOS-OSX clients. This new update includes:

  • Fixed! IP printers were not correctly detected

This update requires the installation of the client software only.

Download WebClientPrint Processor 4.0 for Mac

The “File version” value for this update is:

> wcpp4 patched to v4.0.19.225

WCPP 4.0 for Mac clients Update – Fixed PDF tray and paper size printing

We’re glad to announce a new update to WebClientPrint Processor 4.0 for macOS-OSX clients. This new update includes:

  • Fixed! PDF printing not working properly when tray and paper size was specified

This update requires the installation of the client software only.

Download WebClientPrint Processor 4.0 for Mac

The “File version” value for this update is:

> wcpp4 patched to v4.0.19.219

Barcode Professional SDK 3.0 for .NET STANDARD just released!

We’re proud to announce the new 3.0 release of Barcode Professional SDK for .NET STANDARD!

This new Version 3.0 brings the following features:

You can download v3.0 from our website at
http://neodynamic.com/products/barcode/net-core/download/

WCPP 4.0 for Mac clients Update – PDF files printed at a very small size

We’re glad to announce a new update to WebClientPrint Processor 3.0 for Windows, Mac & Linux/RPi clients. This new update includes:

  • Fixed! PDF files were printed at a very small size

This update requires the installation of the client software only.

Download WebClientPrint Processor 4.0 for Mac

The “File version” value for this update is:

> wcpp4 patched to v4.0.18.115